您的位置: 首页 / PHP, wordpress / WordPress 2.3 Beta 1 插件兼容性的检测方法

WordPress 2.3 Beta 1 插件兼容性的检测方法

Published at Aug 31, 12am / Keywords: ,

WordPress 2.3 Beta 1 发布有两天了,虽然我已经成功完成了升级,但还是不可避免的碰到了插件兼容性的问题。

我花了一些时间研究了 WP2.3 新的分类/Tag 系统,其实插件的不兼容问题多半来自分类数据表结构的“巨变”。目前我已经基本弄懂了新表的结构和操作方案,并在着手修正多款流行插件(例如 Sitemap Generator, Extended Live Archive 等)。但我不可能尝试所有的插件,因此还需要您的帮助,共同找出不兼容的插件。

这里写个我总结的简明兼容性检测方法:

  1. 首先停用现有的全部插件;
  2. 将 Blog 系统升级到 WP 2.3 Beta 1,这里我推荐您在测试平台上完成,若必须在正在使用的平台上升级,请对数据库进行备份;
  3. 删除 wp_categories, wp_post2cat, wp_link2cat 三个表,新版 WP 已经不需要他们;
  4. 启用您认为可能存在兼容性问题的插件;
  5. 如果无法启用,即有兼容性问题;
  6. 如果可以启用,但出现错误提示,则为存在兼容性问题;
  7. 如果可以启用,但功能无法使用,则有兼容性问题;
  8. 如果可以启用,请尝试发布新文章和对现有文章进行修改/删除操作,如果无法操作或出现错误提示,则为存在兼容性问题;
  9. 如果可以启用,请尝试新建、修改、删除 Blogroll,如果无法操作或出现错误提示,则存在兼容性问题;
  10. 请将您检测出有兼容性问题的插件名称插件地址什么操作可引起兼容性问题您的 Blog 名称和地址发送到我的 Email,我会尽快回复,并根据具体情况进行修正。

让我们共同努力,让更多人可以顺利的升级到 WordPress 2.3

[tags]wordpress, plugins[/tags]
发表您的观点或推荐本文 Loading...